Friday, February 8, 2013

LMMS: Fixing distorted sound

So I have been casually using Linux Multimedia Studio, or LMMS, since 2010.  It is a really good free and open source alternative to FruityLoops.

I won't go detailing how great this tool is for digitally creating your music as I am assuming you bump onto this post already knowing what LMMS is.

One issue of this tool on Windows is that LMMS keeps distorting your (if I may) compositions, adding buzz and other weirdness to your music.

The problem is even added on its Troubleshooting page but it is still currently unanswered as of this post.

Luckily, the answer is actually already on its Forums posted by a fellow LMMS user, darkill.  And it's just waiting for someone to add it on LMMS' Wiki.

For archiving purposes (just in case the forums and/or the wiki won't be accessible), let me state the steps here on this post.

Open DirectX Diagnostic Tool
  1. Open a Command Prompt
  2. Type-in: dxdiag
  3. Check the tabs with labels "Sound1", "Sound2", etc.
  4. Check for the Driver's name (mine is STWRT.SYS)
  5. Take note of this now do the next steps 
Update LMMS Settings
  1. Run our favorite digital music authoring tool called LMMS :)
  2. Go to Edit -> Settings
  3. Now goto Audio Settings
  4. Change the Audio Interface to SDL (Simple DirectMedia Layer)
  5. Then specify your Driver's Name of your Audio Device on Settings for SDL
Now restart LMMS and hope that the distortion and other weirdness on your music is gone.

Happy composing!

~creek23

11 comments:

Anonymous said...

oh myens! your awesome. thanks.

Anonymous said...

wow thanks - had problem, found your post, and now its fixed :-))
You are a very cool person!

Anonymous said...

Thanks!!! I recently update LMMS to 1.0.3 and i was unable to play any of my previous projects (LMMS freezes after loading) due to sound rendering problems (LMMS freezes after loading)

Anonymous said...

OMG! You save me! xD
Thanks! =))

john hayes said...

brilliant now I can make music instead of noises with pitch

Anonymous said...

it helped thnx a lot.

Z.H.F. said...

Thanks so much!

Kas said...

I am using LMMS v1.1.3 and it worked for me. Thanks OP!

Jack said...

Every time I change the settings to the appropriate sound and restart LMMS it goes back to the original settings. Help!

dubgamer87 said...

YES! THANK YOU!

mr Eric said...

i don't have sound 1, 2, 3 tab, only 1 sound tab and my driver is Realtek RTKVHDA.sys, i put it in SDl box but nothing change, still have nasty distored sound, what the flippin happen with me